Trelson Assessment writing space issue
Incident Report for Trelson
Postmortem

Summary

All students who opened or resumed an assignment that included the writing space module between 2022-10-06 16:30 CEST to 22:00 CEST and had nothing saved was met with an error message after a few seconds.

Timeline (YYYY-MM-DD)

At 2022-10-06 16:30 CEST a new update was deployed for Trelson Assessment that was supposed to improve communication between two components that are critical for the writing space module in Trelson Assessment.

At 2022-10-06 21:30 CEST a developer is notified that some customers are having issues with the writing space and starts investigating.

At 2022-10-06 21:45 CEST the developer has singled out the issue to be a bug introduced in the latest update done earlier that day and re-deploys a previous version where the issue was not yet introduced.

At 2022-10-06 21:55 CEST the rollback to the previous version has been completed and students who open the app will no longer be impacted by the issue.

Root Cause

We pushed out an update intending to solve a bug we had been notified about previously and did not detect the issue with the writing space module during our internal quality assurance testing before the update was made.

We’ve added steps to our process to prevent this from happening in the future.

Posted Oct 07, 2022 - 16:06 CEST

Resolved
This incident has been resolved. We have re-deployed a previous update where the issue does not happen
Posted Oct 06, 2022 - 22:00 CEST
Investigating
We've received reports that students are having issues with the writing space in Trelson Assessment
Posted Oct 06, 2022 - 21:30 CEST
This incident affected: Assessment.